HOME SEARCH BROWSE ADD CONTACT

Pontiac >> G6 >> 2009 >>

2009 Pontiac G6 - 1G2ZH57N394 - Service Brakes Problems

VIN: 1G2ZH57N394
Location: Sartell, MN
Miles: 0
Date Reported: August 6th, 2012


Description of Problem

While driving, cruise control will disengage and brake lights will flair on. Than when tap brakes, brake lights will shut off. Within a couple seconds, they will turn back on. When actually going to press on the brakes, have no brake lights than. This has also happened without using cruise control, just driving in general. Break lights will come on, than when press on the brake, they shut off. Couple seconds later, come back on. This is a huge safety issue while driving at night time(or during the daytime), not having brake lights when stopping. Do not feel safe driving with my children in the g6. I have looked online, and found that i am not the only one having this issue: http://www. G6ownersclub. Com/forum/showthread. Php? T=6657 is a forum/thread of various g6 owners complaining about this issue and also believes they have come up with what the problem is. From what it sounds like, its a connector with the bcm (body control module) and it developing corrosion.


2009 Pontiac G6 - 1G2ZH57N394 - Vehicle Speed Control Problems

VIN: 1G2ZH57N394
Location: Sartell, MN
Miles: 0
Date Reported: August 6th, 2012


Description of Problem

While driving, cruise control will disengage and brake lights will flair on. Than when tap brakes, brake lights will shut off. Within a couple seconds, they will turn back on. When actually going to press on the brakes, have no brake lights than. This has also happened without using cruise control, just driving in general. Break lights will come on, than when press on the brake, they shut off. Couple seconds later, come back on. This is a huge safety issue while driving at night time(or during the daytime), not having brake lights when stopping. Do not feel safe driving with my children in the g6. I have looked online, and found that i am not the only one having this issue: http://www. G6ownersclub. Com/forum/showthread. Php? T=6657 is a forum/thread of various g6 owners complaining about this issue and also believes they have come up with what the problem is. From what it sounds like, its a connector with the bcm (body control module) and it developing corrosion.